2026-08-15 National Grid onboarding issue

Incident Report for Sense

Resolved

This incident has been resolved.
Posted Aug 15, 2026 - 17:00 EDT

Investigating

A communications problem in National Grid's network in Massachusetts is preventing customers from setting up Sense with their meter. The outage is being investigated.
Posted Aug 15, 2026 - 14:42 EDT
This incident affected: Login.